This project has moved. For the latest updates, please go here.

Error trying to get D3 RoS editor working.

Topics: Help and Support
May 1, 2015 at 7:57 AM
Hi< hoping someone can shed some light.

The editor worked fine on my save before the FW update. Due to my HDD crashing and having to re-install an OFW just to get things working again my console is now on OFW 4.70.

PS3-Decryptor states that the file is allready decrypted
Bruteforce savedata says the paramaeter.sfo file does not exist but it is in the folder.

Takin g a fresh save from the system yields the same results.

When opening it in the editor i get the following


************** Exception Text **************
System.OverflowException: Arithmetic operation resulted in an overflow.
at D3Edit.Form1.backgroundWorker_RunWorkerCompleted(Object sender, RunWorkerCompletedEventArgs e)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

DIII.SaveEdit
Assembly Version: 1.3.17.128
Win32 Version: 1.3.17.128

CodeBase: file:///C:/Users/Valistar/Desktop/d3/DIIIROS.SaveEdit_1.3.17.128/DIII.SaveEdit.exe

System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

D3.Ui
Assembly Version: 1.3.17.128
Win32 Version: 1.3.17.128

CodeBase: file:///C:/Users/Valistar/Desktop/d3/DIIIROS.SaveEdit_1.3.17.128/assets/D3.Ui.DLL

System.Core
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL

CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

D3.GameInfo
Assembly Version: 1.3.17.128
Win32 Version: 1.3.17.128

CodeBase: file:///C:/Users/Valistar/Desktop/d3/DIIIROS.SaveEdit_1.3.17.128/assets/D3.GameInfo.DLL

D3.Protobuf
Assembly Version: 1.3.17.128
Win32 Version: 1.3.17.128

CodeBase: file:///C:/Users/Valistar/Desktop/d3/DIIIROS.SaveEdit_1.3.17.128/assets/D3.Protobuf.DLL

protobuf-net
Assembly Version: 2.0.0.668
Win32 Version: 2.0.0.668

CodeBase: file:///C:/Users/Valistar/Desktop/d3/DIIIROS.SaveEdit_1.3.17.128/assets/protobuf-net.DLL

Any help would be appreciated.
May 1, 2015 at 10:36 AM
Update

Now it actually opens with no errors provided i am online. however now it gives me a bunch of numbers instead of names in my inventory.

am i missing something?
Coordinator
May 1, 2015 at 6:41 PM
Lordslayer wrote:
Update

Now it actually opens with no errors provided i am online. however now it gives me a bunch of numbers instead of names in my inventory.

am i missing something?
Use the latest version.. version .128 will not show numbers in the inventory.