This project has moved. For the latest updates, please go here.

Attack speed not showing the right range.

Topics: Help and Support
Feb 18, 2016 at 11:10 AM
I'm making a belt called The Witching Hour. I'm making it within normal ancient stat ranges just with the stats I want so I don't have to sit and reroll it in the cube for hours. Problem is whenever I select the 5%-7% Attack speed it changes it to 4%-5% once the game loads. When I Look at the ranges in my invetory screen it shows 4-5% & when I take it to the enchanter to see the ranges its says 4-7%

The Stats I'm using are:
550-650 Dexterity OR Vitality (want one of each stat for testing)
110-130 Res All
5-7% Attack Speed
25-50% CHD
1-2 Gold/Health Pickup
1-5.1 Chance to Freeze

Legendary Level: 70
Rarity: 9
Flag: Ancient (22220051) Tried them all
Tier: Base T19

Anybody have a idea why its not working right?
Feb 18, 2016 at 9:57 PM
I'll run a test on this problem and see what happens.
Feb 19, 2016 at 5:23 AM
Ok, any luck? I still haven't figured it out. Maybe a program error?
Feb 19, 2016 at 6:46 PM
I'll be on tonight and test it. I'll pull several in to see all difference
Feb 19, 2016 at 7:15 PM
There are two 5-7% attack speed affixes there was no change on the 2.0.4 patch that caused these to to be different then what they say. When you inspect the range of the item you will notice the enchanter would be the most accurate.. I will ask one of the new generation data managers to see if this is in fact the case you should see a response from one of them soon.. Some times what is displayed in the editor as a stat rage will be close but not 100% due to the way blizzard patch's their stuff.

One thing you must also realize as well is you have a cap of 5 attacks per second overall. During that patch of the game they might have missed a few objects that control the attack percentage.
Feb 19, 2016 at 10:37 PM
Unsure what seems to be the OP problem. I just created it using

item 0
leg lvl 70
ancient 22220057
tier none.

Comes in with 5-7% shown in inventory and at the mystic.

I recreated it with the 2nd 5-7% AS in the list and it worked too.

I tested this on PS4 but OP didn't state which console he was on so it may be different for xbone.
Marked as answer by Demon86RJC on 2/19/2016 at 6:27 PM
Feb 20, 2016 at 1:25 AM
It was the tier quality that was messing up the AS stat. I set it to none using the same stats and properties and it worked. I thought you had to set tier quality never test but thought it would make the turn the item to the lowest stats of that item.

Thank You